프로그램 사용/Blender2016. 11. 22. 21:41

netrender 소스인거 같은데 이런 에러네.. 버전 체크?

def clientConnection(netsettings, report = None, scan = True, timeout = 5):

    address = netsettings.server_address

    port = netsettings.server_port

    use_ssl = netsettings.use_ssl

    

    if address== "[default]":

#            calling operator from python is fucked, scene isn't in context

#            if bpy:

#                bpy.ops.render.netclientscan()

#            else:

        if not scan:

            return None


        address, port = clientScan()

        if address == "":

            return None

    conn = None

    try:

        HTTPConnection = http.client.HTTPSConnection if use_ssl else http.client.HTTPConnection

        if platform.system() == "Darwin":

            with ConnectionContext(timeout):

                conn = HTTPConnection(address, port)

        else:

            conn = HTTPConnection(address, port, timeout = timeout)


        if conn:

            if clientVerifyVersion(conn, timeout):

                return conn

            else:

                conn.close()

                reporting(report, "Incorrect master version", ValueError)

    except BaseException as err:

        if report:

            report({'ERROR'}, str(err))

            return None

        else:

            print(err)

            return None


def clientVerifyVersion(conn, timeout):

    with ConnectionContext(timeout):

        conn.request("GET", "/version")

    response = conn.getresponse()


    if response.status != http.client.OK:

        conn.close()

        return False


    server_version = response.read()


    if server_version != VERSION:

        print("Incorrect server version!")

        print("expected", str(VERSION, encoding='utf8'), "received", str(server_version, encoding='utf8'))

        return False


    return True 

[링크 : https://github.com/WARP-LAB/Blender-Network-Render-Additions/blob/master/netrender/utils.py]


이제야(?) 생각이 나서 콘솔에서 실행에서 에러를 보니.. 크앙..

2.76b랑 2.78이랑은 버전이 다른듯 흑 ㅠㅠ

윈도우 쪽을 버전을 내려야지 머 ㅠㅠ

$ blender

connect failed: No such file or directory

Read new prefs: /home/odroid/.config/blender/2.76/config/userpref.blend

libGL error: unable to load driver: exynos_dri.so

libGL error: driver pointer missing

libGL error: failed to load driver: exynos

Incorrect server version!

expected 1.9 received 1.8

Incorrect master version

Incorrect server version!

expected 1.9 received 1.8

Incorrect master version

Info: Master server found


Incorrect server version!

expected 1.9 received 1.8

Error: Incorrect master version 


+

2016.11.23

윈도우쪽 버전을 맞추어도 여전히 incorrect 버전이라고 뜨네..

python쪽 차이일려나? 미지수네...

'프로그램 사용 > Blender' 카테고리의 다른 글

blender physical simulation  (0) 2018.03.19
blender netrender 잠시 된건가..  (0) 2016.11.23
blender netrender / incorrect master version  (0) 2016.11.22
blender netrender 구조  (0) 2016.11.19
블렌더 강좌  (0) 2016.11.18
ubuntu blender addons  (0) 2016.11.17
Posted by 구차니

댓글을 달아 주세요