Programming/django2018.08.08 17:27

아니.. 앵귤러가 아니었다니.. 이게 무슨소리요 사장양반(?!)


django는 python을 이용한 녀석이라 파이썬과 버전을 맞추어야 한다.

python 2.7대가 고인물이라 이걸 쓰려면 django-1.11 LTS를 써야 하고

그 이상 버전은 python 3.x 대를 쓰면 해결될 듯

그리고 python - pip - djang 순으로 설치하면 끝

일단 귀찮으니(?) 파이썬 2.7 설치부터 주르륵 (윈도우 기준)


다운로드

[링크 : https://www.python.org/downloads/release/python-2715/]


환경변수 설정(윈도우 기준)

C:\Python27

C:\Python27\Scripts


pip 설치 스크립트

[링크 : https://bootstrap.pypa.io/get-pip.py]


pip 설치

python get-pip.py 


장고 설치

pip install django 


장고 프로젝트 생성

django-admin startproject test 


장고 프로젝트 실행

cd test

python manage.py runserver 

python manage.py runserver 8080


[링크 : https://www.djangoproject.com/] - 일단은 웹 프레임워크라고 정의함

[링크 : https://docs.djangoproject.com/ko/2.0/intro/tutorial01/]



장고와 vscode 연동


python lint 어쩌구 받고

pylint 설치하고 하라는대로 설치

[링크 : http://ruddra.com/2017/08/19/vs-code-for-python-development/]


관리 정보 생성

python manage.py migrate

python manage.py createsuperuser

[링크 : https://tutorial.djangogirls.org/ko/django_start_project/]

'Programming > django' 카테고리의 다른 글

django index 페이지 추가하기  (0) 2018.08.09
django 시작..  (2) 2018.08.08
Posted by 구차니

댓글을 달아 주세요

  1. PHP 빼고 모든 언어를 다 사용하시는 건가요?
    아~ PHP도 최근 시작하셨죠? ^^

    2018.08.09 11:10 신고 [ ADDR : EDIT/ DEL : REPLY ]